Nate

Certainly! We do improvements all the time, even while working on audio, the new export, etc. It's true there are many things that would help various workflows, it's just a matter of time until we can get to everything. If you come across something that is not captured on our task tracker, please start a new thread to make new suggestions.
User avatar
Nate

Nate
Posts: 8365

matchzlj

I can`t open spine-runtimes-3.7 spine-ue4 project ,
matchzlj
Posts: 1

badlogic

What version of UE4 are you using? What operating system are you using? What IDE? What error do you get?
User avatar
badlogic

Mario
Posts: 1448

alexandr

Hi Guys!
Tell me please when will be released the official version 3.7?
Projects with which we work in 3.7 beta, do not open with version 3.6
why? How can we resolve this problem? :bang:

Thank you!
User avatar
alexandr
Posts: 5

Nate

3.7 is 99% done. There is one more minor feature to complete, other than that once we've decided it is stable enough, it will be released as non-beta. 3.6 can't open 3.7 projects because 3.7 has features that 3.6 doesn't know about. You can try exporting to JSON with 3.7, then loading that with 3.6. Though the bigger the difference in versions, the less likely this will work.
User avatar
Nate

Nate
Posts: 8365

alexandr

Thank u very much for reply.

Another question.. We exported the project in version 3.7.36 to json format, the mesh animation does not work as it should in spine-cocos2dx 3.6. can you fix this issue? or we should wait next version of cocos? :)

Thank u!
User avatar
alexandr
Posts: 5

kbagnall

Exporting mesh deformations seems to have broke in 3.7.36-beta. Prior versions (at least 3.7.32-beta and older) meshes would export with linear interpolation, now they export 'stepped' given the same spine file.
kbagnall
Posts: 2

Nate

@kbagnall, sorry for the trouble! I'm not seeing that happen though. Maybe you can email your .spine file and explain how we can see the problem? contact@esotericsoftware.com
User avatar
Nate

Nate
Posts: 8365

foriero

I think I have seen the same export issue yesterday. Will send spine project with exported unity skeleton later today.
foriero
Posts: 228

kbagnall

Nate wrote:@kbagnall, sorry for the trouble! I'm not seeing that happen though. Maybe you can email your .spine file and explain how we can see the problem? contact@esotericsoftware.com
On second thought it might have been bezier curve interpolation which is exported as stepped. I'll narrow this down next time I'm at work.
kbagnall
Posts: 2

foriero

Email with repro project sent. Thank you.
foriero
Posts: 228

alexandr

The problem was solved! We exported json file in version 3.7
then imported data (json file) already in 3.6, pointed the way to the images, and corrected mesh animations :party: .

Everything is working. :sun:
Thank you!

---

Hi guys,
Yesterday, I tried to work with skins in version 3.7.
In the preview window, they are not displayed.. :angel: :tmi:
User avatar
alexandr
Posts: 5

Erikari

Hello alexandr, I just tested and I see the skins that I select in the tree or using skin view also in the preview view, do you have the latest beta version?
User avatar
Erikari

Erikari
Posts: 1332

alexandr

Sorry, I worked on this Saturday, there were problems.
Now I updated the version and everything is ok. Thank you!
User avatar
alexandr
Posts: 5

nimbling

Hey!
Are there any plans on including Audio in skins?

I've got a skeleton with a few monsters, and one is a robot another a slime lord, another an alien crab... they make different sounds :)
User avatar
nimbling
Posts: 129

Nate

It's an interesting consideration, but I think skins will likely stay dealing only with attachments. You can use a single audio event and add logic at runtime to choose the right sound based on the active skin. If you are exporting video, you could use audio events for each sound and disable the audio events you don't want to play.
User avatar
Nate

Nate
Posts: 8365

nimbling

Thanks!
I’ll end up doing that at runtime indeed, but... but... it sounds so logical to also preview them using skins? Don’t you think? :)
User avatar
nimbling
Posts: 129

Nate

Sort of. You basically have keys that you only want to apply for a particular skin, which isn't a concept we have yet. Someone else recently had a vaguely similar request, where they have transform constraints that are needed for one skin but not another, and they wanted the skin to remember transform constraints settings so they don't have to adjust them manually. There might be something we can do for these cases, but I'm not sure how much we want to burden skins, especially when the workaround is simple enough (adjust things at runtime as needed).
User avatar
Nate

Nate
Posts: 8365

alexandr

Hello friends!
There are a couple of ideas about usability of spine.

To add tint optionfor animations names in the animation section for easier searching and dividing them into groups by color.
spine2d.jpg


You can also make markers on timeline for the convenience (when we are working with keys switching the bones).
Screen-Shot-2012-08-18-at-3.46.57-PM.jpg


Just some ideas) Have a nice day!
User avatar
alexandr
Posts: 5

nimbling

Nate wrote:Sort of. You basically have keys that you only want to apply for a particular skin
Hi! well, what I meant was, I'd like to keep the keys like I already do, per animation, and then hook up different audio-files to skin slots in the same way I attach different images to different skins.

I guess my feature request is for "Audio support for skin slots" - but I know you're all really busy with other & bigger stuff I will ALSO really appreciate :) Keep up the good work!

Edit I see where my thoughts on this came from: in my mind an audio file is an attachment much like an image is. Which it of course isn't, but in my head it was :)
User avatar
nimbling
Posts: 129

jeffreynuez

Is it safe enough to use the 3.7 beta withought any major crashes now that your working on the 3.8 beta?
jeffreynuez
Posts: 24

Nate

Stability for 3.7 is our top priority right now. Any information about what you were doing just before a crash would be extremely helpful!

There are some crashes in 3.7 that we have not been able to track down. We get error reports of the crash, but it happens when drawing the skeleton. Something the user has done previously puts the skeleton in a bad state, then it crashes the next time it tries to draw the skeleton. Unfortunately the users experiencing these crashes haven't reported what they were doing that might have caused it, so it is difficult to track down.

That aside, 3.7 is otherwise ready to come out of beta. Many beta users don't experience such crashes.
User avatar
Nate

Nate
Posts: 8365

jeffreynuez

awesome, thanks Nate thats great to hear. I've been looking forward to this update for a while now.
jeffreynuez
Posts: 24

scardario

Hi!
It seems I can't delete keyframes anymore by selecting them on the Dopesheet and pressing DEL or Backspace (it used to work some versions ago). The "Delete selected keys" button on the Dopesheet bar is working though.

Using 3.7-50-beta.

Thanks!

--

Sorry for the edits, the Dopesheet seems to be behaving erratically, at first the shortcuts were working but not anymore, sometimes I have to double click on the main window to deselect whatever bone(s) I have selected to be able to select something in the Dopesheet, sometimes when I try to delete a selected keyframe from the Dopesheet it asks me if I want to delete another thing, like the current animation (with the Animations windows visible) or the attachment (with the tree visible). Sometimes I'm not able to create a keyframe on the selected channel by pressing Ctrl+L (particularly with deformations on meshes or paths).
scardario
Posts: 53

Erikari

Hello scardario, Backspace and Del seem to be working for me on 3.7.50-beta.
scardario wrote:sometimes I have to double click on the main window to deselect whatever bone(s) I have selected to be able to select something in the Dopesheet
Do you mean that when you select a different bone, it doesn't change to said bone in the dopesheet? I tried to repro this too but it worked fine for me.
scardario wrote:sometimes when I try to delete a selected keyframe from the Dopesheet it asks me if I want to delete another thing, like the current animation (with the Animations windows visible) or the attachment (with the tree visible).
This is due to the fact that you selected those things last, but then you didn't properly click on a keyframe to delete, but just moved the timeline marker instead.
scardario wrote:Sometimes I'm not able to create a keyframe on the selected channel by pressing Ctrl+L (particularly with deformations on meshes or paths).
I tried to repro this too on stretchyman but it worked fine.

I'm afraid I will need more detailed steps/a gif or video of the problem, otherwise, everything mentioned seems to be working fine.
User avatar
Erikari

Erikari
Posts: 1332


Return to Spine