wiwing

Hi, I have a problem with spine export function especially when exporting spine from command line and btw I'm using mac. Usually my team export all the spine assets using automated python script thus we need to use spine CLI to export things, everything is fine until recently I've updated the spine app to v3.0.08. When exporting spine using CLI, the width and height data in the JSON file is always 0 and I don't know why. But when I try to export without CLI, the width and height is exported correctly in the JSON file. Reverting back to previous version can fix this but some of my spine projects have already upgraded to v3.0.08.
wiwing
  • Posts: 4

nschnepf

I apologize if this has already been covered, but I just installed the current version on my system (32 bit XP).
It installed without issue, but when I attempt to launch the application the program never starts. No error messages, just complete lack of activity.
Is there an error log that I could check? Or are there any other suggestions?
nschnepf
  • Posts: 1

Hinidu

Hi, we have a problem with the CLI exporter: some attachments are consistently getting width and height equal to 1 if we run export from CLI, but if we run export on the same project from Spine itself then everything is fine. I reproduced it with 3.0.07 and 3.0.09 on Windows. There was no such problem with v.2.
Hinidu
  • Posts: 19

Arnissan

Hi! Any ETA for 3.0 Unity Runtimes?
Arnissan
  • Posts: 70

Pharan

@Arnissan
Unity runtimes for v3 is usable now, except for SkeletonUtility. (The .unitypackage link won't be updated until this is done)
You can check news on it here: Unity Runtime v3.0 Update Pending
User avatar
Pharan
  • Posts: 5366

Buko-Studios

Hi all,
Are there release notes somewhere with each version update?
For instance, what is the difference between update 3.0.9 and 3.0.11?
User avatar
Buko-Studios
  • Posts: 2

Pharan

User avatar
Pharan
  • Posts: 5366

Buko-Studios

Thanks! exactly what I was looking for!
User avatar
Buko-Studios
  • Posts: 2

Hinidu

Hinidu wrote:Hi, we have a problem with the CLI exporter: some attachments are consistently getting width and height equal to 1 if we run export from CLI, but if we run export on the same project from Spine itself then everything is fine. I reproduced it with 3.0.07 and 3.0.09 on Windows. There was no such problem with v.2.
Do you have any ideas about this problem? :( Our automated build process is broken because of that and it is quite annoying :sweat:

---

I've just updated editor and launcher to 3.0.11 and got the same result :(
Hinidu
  • Posts: 19

Nate

Erikari, thanks, the Pose tool has been fixed in 3.0.12.

petar, sorry. :( The old sort of flip that flipped on the world axes would have been complex and messy to continue to support. Even continuing to support disable inherit scale and rotation was not easy. You aren't "screwed" exactly since you can continue to use 2.1.27 as if v3 was never released, but I do understand it is frustrating not being able to use the v3 scaling if your project could benefit. Hopefully updating your animations with the new scale/flipping won't be too bad.

wiwing and Hinidu, sorry for the delay. It's better to create a new forum topic so there is more visibility to your issue. Normally Spine saves the image sizes in the project. The CLI export doesn't read the images, so it should use the sizes from the project. It is not clear why the project doesn't have the correct sizes. We haven't been able to reproduce the problem. Can you email a project file that shows the problem when exported from the CLI?

nschnepf, disable Bit Defender or other (terrible) programs.

Arnissan, most runtimes are updated to v3. The rest will be done soon.
User avatar
Nate

Nate
  • Posts: 12129

liquidzym

i had same issue like puzzler mentioned before,everytime launch the spine will be connecting to the server and download 3.xx(whatever the newest version is) again.
i did set up using 3.0.12 in setting panel. but that doesn't help.

any ideas? cheers

---

sorry for asking,but i'm still had this issue,is there anyway to fix it?
btw,here's my spine.log

Spine Launcher 3.0.13
Windows 10 Pro x86 6.2
Java 1.7.0_06 Esoteric Software
32-bit Server VM
Download required. (2050)
Unable to save shared data.
java.util.prefs.BackingStoreException: flush(): Backing store not available.
at java.util.prefs.WindowsPreferences.flush(WindowsPreferences.java:791)
at java.util.prefs.WindowsPreferences.sync(WindowsPreferences.java:821)
at tzax.I.a(SourceFile:162)
at tzax.I.a(SourceFile:143)
at tzax.h.run(SourceFile:879)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:711)
at java.awt.EventQueue.access$000(EventQueue.java:104)
at java.awt.EventQueue$3.run(EventQueue.java:672)
at java.awt.EventQueue$3.run(EventQueue.java:670)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:681)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)
Downloading: Spine 3.1.01
Update complete.
Spine 3.1.01 Professional, LWJGL
Licensed to: *****, *****
NVIDIA Corporation
GeForce GTX 870M/PCIe/SSE2
4.5.0 NVIDIA 361.91
Started.

and the update folder contains version 2.1.27 and 3.1.01
liquidzym
  • Posts: 3

Nate

Sorry we haven't yet had bandwidth to fix the downloading every run.

It is odd that you get that error, but it will not affect how Spine is working for you.
User avatar
Nate

Nate
  • Posts: 12129

liquidzym

ok,it just a bit annoying,have to wait for downloading. anyway,thxs for the help.
liquidzym
  • Posts: 3

jbnatali

Hi there,

Since the latest version of Spine, I have noticed that, once imported in Unity, white lines appear where the texture is not fully opaque (edges of pngs). It has generated some issues, we tried to solve tem by using non-spine-default shader, but it would generate new issues.

Is there a well-known problem with the current shader in Unity since the latest version was released?

Help very appreciated cheers
jbnatali
  • Posts: 4

Pharan

@jbnatali
There have been no changes to the shaders in 2 years: https://github.com/EsotericSoftware/spine-runtimes/tree/master/spine-unity/Assets/spine-unity/Shaders
Is this what you're seeing? Premultiply Alpha
User avatar
Pharan
  • Posts: 5366

foriero

HI, WE HAVE FOUND THE ISSUE. IT IS BECAUSE DUPLICATION IN NAMES. THANKS, MAREK.

Hi, we can not import this json file in latest Spine. Since Spine gives us only it is not a valid format we don't know what is wrong.

Nate can you please check it and tell us where we make mistake?

Also would be nice to have some kind of feedback where the json failed to load then we can fix it.

https://www.dropbox.com/s/dh2xjsl40r2pudr/music_school_spine.json?dl=0

Thanks a lot, Marek.

---

I see there is new line in json file :

{"hash":"pdD0ErXkN4vs8JRBipQI7VOsXX4","spine":"3.1.02","width":212.12,"height":246.64,"images":"./images/"},

Is there documentation to it?

We used to add Resolution Tag to json since we needed to know what target resolution that particular file targets. Now i see width and height which seems to have the same purpose right?

Do we need to include hash? How to obtain it if we export json from illustrator?

Also is Spine version obligatory or must have?

Thanks, Marek.

---

Anyway I tried to add the new line into our json and it still fail to import. :-(

https://www.dropbox.com/s/j730apcdb2k4ie8/music_school_spine_with_hash.json?dl=0
---

Tried to validate json here : http://jsonlint.com/ and everything seems to be ok. So where we make mistake?

Thanks, Marek.
Founder & CEO Foriero s.r.o.
https://studio.foriero.com
User avatar
foriero
  • Posts: 472

fish1986

我想知道3.0.00版本的animation如何打开2.1.27版本的animation?
fish1986
  • Posts: 1

seminz

i work with the 2.1.27 for an html5 project. Can i update to the 3.0.7 ? the html5 runtime is ok for this new version ?
seminz
  • Posts: 25

Søren

seminz wrote:i work with the 2.1.27 for an html5 project. Can i update to the 3.0.7 ? the html5 runtime is ok for this new version ?
Which runtime are you using exactly?
User avatar
Søren

Shiu
  • Posts: 2452

seminz

Hi. can i control bone LOD or simular thing?

becuase i wanna control fece gestures and detail gesture..

but i will be come hard load(?) to cpu

and when fade out , it will not be needing.

So i 'm wondering i can control bone LOD

thx...
seminz
  • Posts: 25


Return to Editor