Solgryn

Hi,

Im trying to play this animation in my game and whenever I play it after the update, I get these new errors.


This is the animation im playing
https://drive.google.com/uc?id=1u-RNxG58sF_ZOaaTAZmBXHDcQdaQVlZz

It's because my mesh is completely clipped (as in hidden)? Is this not allowed? I used to be able to play it, though.

Thanks
User avatar
Solgryn
Posts: 45

badlogic

Could you send us your Spine project? An export with atlas is sufficient. contact@esotericsoftware.com.
User avatar
badlogic

Mario
Posts: 1564

Harald

Drawing clipped meshes is definitely allowed. We have not yet encountered such an issue.

I guess you have re-export all assets from the Spine 3.7 Editor, right? Do your other assets work as expected?
Do you find anything in regards to Pharan's upgrade guide that you could have missed?
Spine-Unity 3.6 to 3.7 Upgrade Guide
Are you using the SkeletonAnimation component, Skeleton Mecanim or SkeletonGraphic (UI)?
User avatar
Harald

Harri
Posts: 147

Solgryn

Okay, so I just spent a lot of time testing.

I made a new SkeletonAnimation testing the animation - didn't have the bug.

I ripped out my SkeletonAnimation from my bugged object and tested the animation by itself with no other scripts - had the bug.

I made a new SkeletonAnimation, Inserted the scripts onto it and put it back into my Player gameobject
Tested the animation - no bugs.

I literally have no clue, the SkeletonAnimation component was bugged somehow and was a freak occurrence I guess (Possible a unity bug?). Luckily it was an easy fix, just remake the object.

thanks for your help
User avatar
Solgryn
Posts: 45

Harald

Thanks for getting back to us. Good to hear that it did not occur this time. Such bugs could be the result of either Unity's quite inconsistent order in which the different initialization methods are called when assets are modified, or even bugs on Unity's side (or flawed design). So if this problem occurs again, please let us know - we would be happy to know the steps to reproduce the problem, or even better a minimal project that shows the problem.

Maybe it is also related to this bug, which we can reproduce in the meantime:
[unity] SkeletonPartsRenderer mesh tangent error · #1265
If you should encounter it once more - we are working on the above issue, hopefully it will cover your problem as well.
User avatar
Harald

Harri
Posts: 147


Return to Unity