Pharan

Step 1: Select a bunch of bones (in the tree) (with slots and images attached to them)
Step 2: Delete.

Confirmation Dialog asks if you want to "delete these bones and all child bones".
Click Yes.

Step 3: Only first bone in the selection (and its descendants) get deleted.


Admittedly, this is a really scary operation that I rarely do it. xD But it's a bug (also reported by my friend).
User avatar
Pharan
  • Posts: 5366

Nate

Fixed, thanks!
User avatar
Nate

Nate
  • Posts: 10562

Adam

I think I've found a bug (or it's a feature? Maybe I'm missing something)

I can delete selection if I have only slots or only bones selected.

But - if I have selected multiple slots and bones, I can't delete the selection.

I know that when I delete the bones, it will delete everything what is attached. But usually I have the bone expanded so I see what's attached, then I shift+select or cmd+select all Items I need to delete and delete it.

Is that a bug or a feature? :D

Also… a "Delete key" keyboard shortcut would be very handy.
Mac OS X, Starling.
User avatar
Adam

Kickstarter 2 backer
  • Posts: 150

Nate

The properties in the tree only show up for a selection of the same kind of items, so it is a feature. :)
User avatar
Nate

Nate
  • Posts: 10562

Adam

Ah, I understand,
but doesn't "Delete" work for all items the same way?
Mac OS X, Starling.
User avatar
Adam

Kickstarter 2 backer
  • Posts: 150

Nate

It just isn't implemented.
User avatar
Nate

Nate
  • Posts: 10562

Adam

oh, I see, all right :D
Mac OS X, Starling.
User avatar
Adam

Kickstarter 2 backer
  • Posts: 150


Return to Bugs