NewSorry

Ok I've been looking for a while and I'm sorry in advance for this, as I'm sure it's ridiculous.
I want to make a logo do what the Facebook live "like" logos do.
I want it to follow a path. I just cannot get the logo to stay orientated. It changes as they bone moves along the path I've set (great on figured it out that far).
I want the logo to remain upright (not to rotate as the bone does) as it floats along the path.
Can I just assign the root to follow the path? I'm stuck and feeling dumb, this is my first day. Thanks!
NewSorry
Posts: 7

Erikari

Hey NewSorry, welcome on board!
I assume the path is not straight, just unlink the sliders in your path constraint Mix settings and set Rotate to 0 (:

User avatar
Erikari

Erikari
Posts: 694

NewSorry

Unfortunately, that just continues to make the logo rotate automatically at each node in the path.
NewSorry
Posts: 7

Erikari

Could you post your project/a screenshot of your path contraint settings, please?
User avatar
Erikari

Erikari
Posts: 694

NewSorry

Will do as soon as I'm off work. Appreciate the help. I'm sure it's something simple.

---

Ok here it is, thank you in advance.
Attachments
ugh trying.spine
(986 Bytes) Downloaded 55 times
NewSorry
Posts: 7

Nate

Thanks. As Erika described above, set your path constraint rotate mix to zero:

That means the path constraint doesn't affect the bone's rotation. Now when you change the position of your path constraint, the bone translation is constrained but the rotation is not. You can animate the bone's rotation normally or not at all if you like.

Please see this page:
Path Constraints - Spine User Guide: Rotate mix
User avatar
Nate

Nate
Posts: 7625

NewSorry

As far as I could tell, I had my rotation set to 0... I'll look at the again after work, but I already tried that. Appreciate the help I'll get back with you.

---

My aim is obviously to animate with zero rotation so at least we have an understanding lol

---

So yeah my rotation is at zero, yet the sprite still waves along with the bone... rotating away. :(
NewSorry
Posts: 7

Wafer

NewSorry wrote:
So yeah my rotation is at zero, yet the sprite still waves along with the bone... rotating away. :(
Maybe you set mix at zero in animation mode? So you have keyframe with 0 at start and then it goes to 100.
Wafer
Posts: 3

Erikari

Here's the same project you sent us, with a small animation - not rotating. All I did was lower the mix, and it's working. Is it working for you too if you open it?
Attachments
try-this-path.spine
(1012 Bytes) Downloaded 55 times
User avatar
Erikari

Erikari
Posts: 694

NewSorry

Erikari wrote:Here's the same project you sent us, with a small animation - not rotating. All I did was lower the mix, and it's working. Is it working for you too if you open it?
Wow yeah that's perfect. Unfortunately I have no idea what you did that I didn't do lol, ugh such a greenhorn. Thanks so much!
NewSorry
Posts: 7

Nate

You simply must not be setting the rotate mix to zero. If you were, it would behave as in Erikari's project. :)
User avatar
Nate

Nate
Posts: 7625


Return to Editor