madbaek

This used to work perfectly but for some reason, it is not working as intended.
If I export JSON from Spine, and copy and paste it to the already existing JSON location folder, not all, but some events are removed in the process. I attached the two files so that you can see them.
1.png

2.png


I assure you that the update process worked well before the recent update. It updated the event keyframes without additional touches.
PS. I'm using Spine Mechanim and afaik these animation clips were auto-generated with that.
You do not have the required permissions to view the files attached to this post.
madbaek
  • Posts: 9

Misaki

Sorry for the trouble. Could you please tell us what version of the Spine editor and the spine-unity runtime you are using?
User avatar
Misaki

Misaki
  • Posts: 1020

madbaek

Spine 4.1.11 and spine-unity 4.1
madbaek
  • Posts: 9

Harald

Could you please send us your problematic exported Spine assets (the three files)? You can send them to contact@esotericsoftware.com, briefly mentioning this forum thread so that we know the context. Then we can have a look at what's going wrong.
User avatar
Harald

Harri
  • Posts: 4328

madbaek

Harald wrote:Could you please send us your problematic exported Spine assets (the three files)? You can send them to contact@esotericsoftware.com, briefly mentioning this forum thread so that we know the context. Then we can have a look at what's going wrong.
I just sent them. I hope there's a way to fix this.
madbaek
  • Posts: 9

Harald

Thanks for sending the reproduction assets, we received everything.

Strangely the animation born of the .json skeleton file does not contain any events at all (which obviously explains your observed behaviour). If you are you sure that it does in your project, could you please also send us the Spine project files? Please also briefly mention this forum thread URL in your email as a reference, so that we know immediately where it belongs to.
User avatar
Harald

Harri
  • Posts: 4328

madbaek

Harald wrote:Thanks for sending the reproduction assets, we received everything.

Strangely the animation born of the .json skeleton file does not contain any events at all (which obviously explains your observed behaviour). If you are you sure that it does in your project, could you please also send us the Spine project files? Please also briefly mention this forum thread URL in your email as a reference, so that we know immediately where it belongs to.
I included the project file in the same zip file I sent. You can check it out.
madbaek
  • Posts: 9

Harald

Oops, sorry, I must have overlooked the .spine file in the top directory.

---

It seems that having Animation cleanup enabled upon export leads to removing those two events. We will investigate why this happens.
Until that issue is resolved, please disable Animation cleanup when exporting the project. Thanks for reporting!

---

This issue has been resolved in Spine version 4.1.12.
User avatar
Harald

Harri
  • Posts: 4328


Return to Unity