RukichanNanodesu

Hello!

We’ve encountering some difficulties that we cant solve on our end and hoping if we could get some assistance.

Issue:
Using Spine's URP Sprite shader and enabling Write to Depth causes a graphical glitch (seemingly only on M1 Macs, as we didn't notice the issue occurring on a PC).

Please see included video in the dropbox for reference

https://www.dropbox.com/s/o2tot99g5vtgcbb/SpineURPSpriteShaderIssueOnM1Mac.mp4?dl=0
You do not have the required permissions to view the files attached to this post.
RukichanNanodesu
  • Posts: 4

Harald

Sorry for the troubles. Thanks for sending the reproduction project and for posting here on the forum.

It seems as if the problem comes from the background skybox being rendered after the skeleton which is rendered in the queue AlphaTest (Transparent Cutout). Rendering the rather costly skybox at the end of the opaque queue (even after AlphaTest which counts as having no semi-transparent pixels) is quite common and a reasonable "optimization".

The issue should be resolved automatically when any real (opaque) content is placed between the skeleton and the background skybox, or the Camera setting is changed crom skybox to solid color and updated (cleared) every frame.

Another solution would be to set the shader Material property Render Queue Offset to 550 to change the skeleton from AlphaTest to Transparent.
User avatar
Harald

Harri
  • Posts: 4328

RukichanNanodesu

Understood, thank you so much for the prompt reply as always!
RukichanNanodesu
  • Posts: 4

Harald

You're welcome.
User avatar
Harald

Harri
  • Posts: 4328


Return to Unity