Azub

Hello!

I've been toying with spine lately but I have a problem with importing a spine skeleton to game maker studio 2. Everything works and looks fine in spine but when I export it to gms it looks quite pixelated and ugly. I have searched the forums and tried to change the spine export functions but nothing has helped yet.

I'm using the latest gms 2 runtime (steam runtime v2.1.1.158) and Spine v3.4.02 (the latest gms 2 supports).

This is what the image looks like in Spine (and how it should look):

spine.jpgThis is what the image looks like in Spine


And this is what it looks like after exporting to gms 2 (also looks like this when viewed in skeleton viewer)

gms2.jpgThis is what it looks like in gms2


Here's the spine export settings I'm using:

spine_2.jpg


Any help is greatly appreciated!
Azub
Posts: 3

Pharan

These are settings that need to be set in GameMaker.
You may have better luck asking in their forums. We don't actually maintain GameMaker's Spine support.
User avatar
Pharan

Pharan
Posts: 4444

Nate

Aye, first ensure it looks correct in the texture atlas. If so, it's a GM rendering issue. If they are doing linear filter and that is blurring your images, maybe they have settings to choose nearest neighbor filtering.
User avatar
Nate

Nate
Posts: 7538

Azub

Thanks for answering. I already asked in their forums before posting here but haven't gotten any answers so far. The reason I'm asking here also is because it looks the same even when viewed in skeletonviewer. That's why I thought it might be some of my settings in spine. I'll check how the atlas looks and play with gamemakers settings when I have time.
Azub
Posts: 3

Nate

Skeleton Viewer uses the filtering settings from the atlas file, which you have set to linear in your texture packing settings:

Nearest should give you a more pixelated look.

---

We've updated Skeleon Viewer to have a Filtering checkbox. It defaults to checked if all the filter settings in the atlas are linear. When clicked it overrides the atlas settings with linear or nearest.
User avatar
Nate

Nate
Posts: 7538

Azub

Thanks for your help Nate! I checked the gamemaker settings and you were right. I had forgotten to uncheck "interpolate colours between pixels" -box when starting a new project. When unchecked the image looks a lot more like it does in spine (still not exactly the same but close enough, at least it's not blurred anymore in game).
Azub
Posts: 3


Return to Editor