barrcodes

I'm having an issue with Solve Tangents. Your example scene is working fine, but when I apply Solve Tangents to my own sprite I have issues. If I override the sprite's motion with SkeletonUtility, the tangents appear to solve. But if I run an animation, the tangents appear static.

See the following image for details. I am debugging worldNormals to show the issue. The attached issue is in my homebrewed shader, but the same issue appears if I try to apply your out-of-the-box shaders.
Attachments
WorldSpaceNoms-Info.png
barrcodes
Posts: 10

Pharan

Sorry, I didn't notice this thread!

We'll check this problem out.

Are you on Spine 3.6 or on 3.7?
User avatar
Pharan

Pharan
Posts: 5281

barrcodes

No problem! Let me know what I can share with you to help this go smoothly!

I believe 3.6. The runtime in unity says "This runtime works with data exported from Spine Editor version: 3.6.xx" ... can't find any other versioning info. Should we attempt an upgrade?
barrcodes
Posts: 10

Pharan

No, but if you haven't done so recently, update it using the latest 3.6 unitypackage.
Spine Unity Download

There was a bugfix earlier this year (still 3.6) that fixed a problem with tangents not being updated.
User avatar
Pharan

Pharan
Posts: 5281

barrcodes

Updated. Same issue currently. I may be willing to make a simple example scene to send your way, if you're interested.
barrcodes
Posts: 10


barrcodes

Pharan, you should have just received a Google Drive link from me to share a sample project. Let me know your thoughts, or if you have any questions about my process.

One small additional bug: if you make the camera orthographic (ortho size 7) in that scene, the z-sort order of the slots gets all messed up.
barrcodes
Posts: 10

Pharan

I can confirm that we've received the email but I can't seem to access the folder.

Regarding the sort order, if you're not using a depth-reading/writing shader, is your problem similar to the problem in this thread?
Spine Animation rendering problem
User avatar
Pharan

Pharan
Posts: 5281

barrcodes

What does it say when you try to access? Make sure at the top right of your Google drive page that you are accessing as unity@esotericsoftware.com ... Or if that's an alias, please give me the email address you are using.
barrcodes
Posts: 10

badlogic

User avatar
badlogic

Mario
Posts: 1448

barrcodes

Thank you. I sent it to the new address. I also added sorting groups, and it worked. Thank you, Pharan!

---

I'm sure this is clear, but just in case: sorting groups fixed the orthographic camera issue. Tangents are still wrong in animation.
barrcodes
Posts: 10

Pharan

Thanks, we've received the repro case.

I think I found the problem. Just something weird with submesh counts we're doing. It only manifested when the renderer uses multiple submeshes.
I'll push a fix soon. Stay tuned.
User avatar
Pharan

Pharan
Posts: 5281

barrcodes

Thank you! I think we would prefer to be using one mesh, I just had some issues when I tried to bake my skin at runtime. I probably need to take another look at that.
barrcodes
Posts: 10

Pharan

Can you try the latest unitypackage now? It should be dated today (November 15)
Spine Unity Download

There were a few additional related bugs that I ran into that should have been fixed in the process.
Let us know if you run into any problems with the runtime!
User avatar
Pharan

Pharan
Posts: 5281


Return to Bugs