Pharan

A user recently ran into this problem so I'm leaving this guide here in the meantime.

Spine's 2D Toolkit support is enabled and disabled via scripting symbol defines in your project's target platforms.
You can enable it by going to Unity's Preferences...>Spine and clicking on the Define TK2D "Enable" button.
Unity_2017-12-17_09-34-05.png


You can click "Disable" to remove those scripting symbol defines.

This is an opt-in feature, to prevent it from referencing the TK2D classes that don't exist if you don't have 2D Toolkit added to your project.

If you closed your project with the SPINE_TK2D symbol defined but without 2D Toolkit in your project, the next time you open your project, the Spine editor preferences panel will fail to compile because the whole assembly in general is unable to find TK2D classes. So you won't be able to remove the defines through the preferences panel.

In this case, you will have to remove them manually.
You can find your project's scripting define symbols under the Player settings.
Unity_2017-12-17_09-16-12.png
Unity_2017-12-17_09-16-52.png


Just remove "SPINE_TK2D" for each of your target platforms and it should be able to compile properly again.
User avatar
Pharan

Pharan
Posts: 5220


Return to Unity