mainhard

Hi,

Before purchase Spine, I have to check if it will works fine with spine-js runtime (https://github.com/EsotericSoftware/spine-runtimes/tree/spine-js/spine-js). I get latest available trial version and try to change Spine version by using "Spine Settings" ->"Version" (instead of "Latest" -> "3.1.08"), because of according to description spine-js runtime "Spine-js works with data exported from Spine 3.1.08. Updating spine-js to v3.2 and v3.3 is in progress.".
After selecting "3.1.08" version I do restart Spine and I see latest version again (attachment Spine_restart.png).

Looks like bug. Is there is any other way to check Spine 3.1.08?

WBR, Vadym.
Attachments
Spine_restart.png
mainhard
Posts: 1

Nate

That is a bug, but maybe not the one you expect. The trial is always the very latest version of Spine (beta if a beta is the latest). The trial should not show the settings for changing the version.

Note you are looking at the spine-js branch. If you look at master you'll see that spine-js has been replaced by spine-ts, which is much more advanced and works with exports from 3.5.xx. There is also a 3.6-beta which works with exports from 3.6.xx, but some functionality may be a work in progress.
User avatar
Nate

Nate
Posts: 7429


Return to Bugs
cron