djmisterjon

since last update 3.8.13


the pixi guys are too busy and will not able to make update for a few months.

so i try come back to last worked version but now i get this error in the editor when i load my work.


do i lost all my work? :'(
djmisterjon
  • Posts: 67

Shiu

There is a good chance that you can open the Project in 3.8.13-beta, then export the JSON file (with Nonessential data checked). Load up 3.8.11-beta and Import Data.

If this doesn't work for you, Spine makes backups of your projects while you are working. You can find the backup folder by going to Settings and then Files and click Open next to Backups.

I hope this helps!
User avatar
Shiu

Shiu
  • Posts: 2380

Nate

You can't open newer projects with an older version of Spine. In this case Shiu's suggestion to export JSON will not work because the JSON format has changed. We have updated the JsonRollback tool so you can use that to convert 3.8 JSON to 3.7. This thread explains it:
Spine editor and runtime version management
Use the 3.8 skeletonViewer-beta.jar and run it like:
java -cp skeletonViewer-beta.jar com.esotericsoftware.spine.JsonRollback input.json 3.7 output.json
Where input.json is from 3.8. The tool will write output.json which you can then import into 3.7.
User avatar
Nate

Nate
  • Posts: 9241

badlogic

Note that we've updated spine-ts to support the latest JSON format exported from 3.8.12 onwards. You should be able to update pixi-spine yourself by simply replacing the sources in this folder https://github.com/pixijs/pixi-spine/tree/master/src/core. Then follow the build instructions for pixi-spine in the README.md.
User avatar
badlogic

Mario
  • Posts: 2073

djmisterjon

thanks all for help, am able to get back my projet .. fiouww
:D
djmisterjon
  • Posts: 67

Shuiliandong

Thank all for help.
Shuiliandong
  • Posts: 4

AprilC

Hi,

can someone explain how to do this? Is it done in Spine software or in the code?

I have the same problem but could not understand how to make this work.
AprilC
  • Posts: 8

badlogic

You have two options if you run into this issue:

1. You take your 3.8 projects and roll them back to 3.7, so you can continue using the current pixi-spine version. Nate described it in this post: 3.8.13 crash pixijs and corrupted project file Search this

2. You update the pixi-spine code as described here: 3.8.13 crash pixijs and corrupted project file Search this

For 2. I believe the pixi-spine folks have already updated though. So maybe you can just grab the latest pixi-spine release and it works with your latest 3.8 exports.
User avatar
badlogic

Mario
  • Posts: 2073

badlogic

You have two options if you run into this issue:

1. You take your 3.8 projects and roll them back to 3.7, so you can continue using the current pixi-spine version. Nate described it in this post: 3.8.13 crash pixijs and corrupted project file Search this

2. You update the pixi-spine code as described here: 3.8.13 crash pixijs and corrupted project file Search this

For 2. I believe the pixi-spine folks have already updated though. So maybe you can just grab the latest pixi-spine release and it works with your latest 3.8 exports.
User avatar
badlogic

Mario
  • Posts: 2073


Return to Bugs