Lavennin

Unity 5.6, Spine & Spine-Unity runtime 3.6

Used SkeletonAnimator instead of SkeletonAnimation in scene, and encountered the error:

Animator is not playing an AnimatorController
UnityEngine.Animator:get_layerCount()


The controller is the default one; I didn't change it, simply set the clips up. There's only the base layer and no parameters used.
Hmmm...what did I do wrong? I tried google this error, but seems it's relatively rare. :think:

Thanks!
Lavennin
Posts: 1

Dmitriy Makeyev

A similar mistake about which I also wrote. Please correct.
Dmitriy Makeyev
Posts: 30

Pharan

Thanks for reporting. Comparing the old and new code, it sort of doesn't make sense why it would throw that warning.
But it should be handled in the next update.

If you want to apply it to your SkeletonAnimator.cs immediately, use this code: https://raw.githubusercontent.com/EsotericSoftware/spine-runtimes/3.6/spine-unity/Assets/spine-unity/SkeletonAnimator.cs
User avatar
Pharan

Pharan
Posts: 5032

TedNindo

I am having the same warnings. A lot of them. Quite sure they are new so I am not sure why they pop up.

I am using the runtime version 3.6.x.x Since this thread is over 8 months old I think I should have the fixed version.

Animator is not playing an AnimatorController
UnityEngine.Animator:get_layerCount()
Spine.Unity.MecanimTranslator:Apply(Skeleton) (at Assets/spine-unity/SkeletonAnimator.cs:161)
Spine.Unity.SkeletonAnimator:Update() (at Assets/spine-unity/SkeletonAnimator.cs:78)


The link above is dead so I can't fix it myself-
TedNindo
Posts: 22

Pharan

Did the warnings appear just now? What changed?

Are you using the latest? This should be included in the unitypackage by now.
Spine Unity Download
User avatar
Pharan

Pharan
Posts: 5032

TedNindo

Thanks, Pharan,
I updated once more, as it seems I did not have the very last version of the runtime libs. Seems as if the errors are gone. Thanks a lot.
TedNindo
Posts: 22

wayward_ed

I've just started using Spine (great software package!), and I'm seeing these same warnings with the latest unity runtime (the one dated 4/25).

Animator is not playing an AnimatorController
UnityEngine.Animator:get_layerCount(Animator)
Spine.Unity.MecanimTranslator:Apply(Skeleton) (at Assets/ImportedPackages/Spine/spine-unity/Components/SkeletonAnimator.cs:180)
Spine.Unity.SkeletonAnimator:Update() (at Assets/ImportedPackages/Spine/spine-unity/Components/SkeletonAnimator.cs:82)

They don't happen all the time, but every now and then I'll do something in the editor that tickles this and causes these to appear when I make any changes to the scene. If I run the game and then drop back into edit mode, they go away for a while, but they always seem to come back.
wayward_ed
Posts: 1


Return to Unity