Jargoon

Hello,

Can't seem to open my project. I get the message "sorry, an error occurred reading the project file."

It was made in a version prior to 2.1.08 because I'm using GM Studio. I didn't update it much, the last time I exported from the project file was in December 2015 and I first created the project earlier that year.

I haven't opened it for a few months, tried now after doing a fresh install of Spine and it won't open. I've tried various versions as far back as the 1.x era and I can't seem to open the file.

Any advice? Could it have somehow corrupted? None of my other Spine projects are working either so that seems unlikely to me.
Jargoon
  • Posts: 2

Nate

Can you email the .spine file and link this post? contact@esotericsoftware.com
User avatar
Nate

Nate
  • Posts: 12129

Jargoon

Alright will do.

EDIT: I just learned you can Import Data using exported Spine data and it can turn it back into a project file. This is useful if anyone is having problems with a broken project.

EDIT2: Esoteric looked into it, they were able to open my file in 2.1.27. I don't recall upgrading past 2.1.08 but I can confirm my project does open in 2.1.27 on my machine as well.
Jargoon
  • Posts: 2

Nate

Good point, I should have mentioned data import.

Glad you got it to open. I'm guessing you used 2.1.27 at some point, which was the latest version for a while. Keep in mind, older versions of Spine cannot open projects saved with newer versions. Newer versions of Spine can always open projects saved with ANY older versions.
User avatar
Nate

Nate
  • Posts: 12129

Jan-Ahoiii

Hi Esoteric-Guys. I have the same problem. The Problem is, that I did not export a json data of the project and downgrading spine does not help.
Can I please send you my spine data? I opend it with an editor, but it looks empty.... But it has 9kb.
Would be very nice if you can help me. Alot of work would be lost.
Jan-Ahoiii
  • Posts: 19

Pharan

@Jan-Ahoiii
Remember that Spine also auto-saves older versions of your project. You can go to Spine>Settings... and look for the Backups item in Settings and click the Open button.

You can at least retrieve the last working version that way.
User avatar
Pharan
  • Posts: 5366

Nate

Jan-Ahoiii wrote:Hi Esoteric-Guys. I have the same problem. The Problem is, that I did not export a json data of the project and downgrading spine does not help.
Can I please send you my spine data? I opend it with an editor, but it looks empty.... But it has 9kb.
Would be very nice if you can help me. Alot of work would be lost.
Try backups, as Pharan mentioned. What version do you open it and it's empty? You can open it with the latest version, export JSON, and import that to an older version (you may need to fix up the JSON first).
User avatar
Nate

Nate
  • Posts: 12129

Jan-Ahoiii

Sorry for not coming back to that topic. A made a new file... It´s good to know that there is backup function in future!!
Thank you for your help!!!
Jan-Ahoiii
  • Posts: 19

Till

I just encountered the same error for the first time. After reading through this thread I opened up some of my backup files too see if it was just my work scene that got corrupted however they all had the same error. I tried to open a different project altogether and that worked fine which confused me...

Then I noticed that there were files in my backup folder that had a "-beta" extension at the end. After trying out a few i realized that these are all the ones that weren't loading. I never signed up for some sort of beta version of the software so I'm unsure where this is all coming from.

Any help would be greatly appreciated.
User avatar
Till
  • Posts: 1


Return to Editor