ericbdg@gmail.com

Hi,

I've recently got an error message like this :sweat: :



Can you explain why? Was it the export options or runtime issues?

Currently exporting with spine version 3.6.5.0

I've attached the complete project below.

Any suggestions would be much appreciated.
You do not have the required permissions to view the files attached to this post.
User avatar
ericbdg@gmail.com
  • Posts: 37

Erikari

I'm no Unity expert, but it might be because the atlas file needs to be renamed to atlas.txt
User avatar
Erikari

Erikari
  • Posts: 1633

Harald

@Erikari is right, the zip file shows that the atlas has the suffix .atlas instead of .atlas.txt which is required by the Unity runtime.

Please change the export options under Export - Pack Settings in the Spine Editor so that the atlas extension lists .atlas.txt:

ExportOptions1.PNG
ExportOptionsAtlasTxt.png
You do not have the required permissions to view the files attached to this post.
User avatar
Harald

Harri
  • Posts: 327

ericbdg@gmail.com

@Erikari @Harald, thanks for the input.

The programmer finally found the solution, it was the CAPS on the file name and the main root bone. You see, I was working on two project, one was using unity and already established to use CAPS on file names and root bone names, the other was using cocos 2d, and was using small letters for file names and root bones. I don't know that these things can really affect the material loading. I got mixed up in the middle.
User avatar
ericbdg@gmail.com
  • Posts: 37


Return to Unity