itsmylifesoham

Hi,

I am a new user and just downloaded unity 2019.1.14f1 . I downloaded the latest spine-unity right now which is 3.8 and imported package. instantly got errors. :'(

---

I was able to fix these by changing the SprinePreferences handleScale property as non-static and a couple other changes. How about the first warning though ? There is a file with name Animation.cs .
You do not have the required permissions to view the files attached to this post.
itsmylifesoham
  • Posts: 2

ophtalmic

I got same errors in unity 2019.2.9f1 version, when i import spine 3.8 unity package. I don't have any scenes or anything. Just opened new project and imported spine package.
ophtalmic
  • Posts: 2

pab

I'm having the same problem. Is there a solution for this? Also using Unity 2019.2.9f1
pab
  • Posts: 1

blockedProject

BUMP
Also happening to us.
When I import spine into an empty project I get 13 compiler errors.
This needs to be fixed ASAP as it is blocking our project right now.
blockedProject
  • Posts: 1

Nate

Sorry for the trouble! This commit on Friday was no bueno:
https://github.com/EsotericSoftware/spine-runtimes/commit/5b98c80d326ea6d13250dcb4cc2980db690fbb4e
Will get this fixed up ASAP and post here when it is done.
User avatar
Nate

Nate
  • Posts: 9471

Harald

The errors have been fixed and new unitypackages can be downloaded:
Spine Unity Download

I'm very sorry for the troubles! I have messed this up, these errors slipped through since they occurred only on newer Unity versions (and separate code branches). This will be added to automated testing tomorrow to not happen again.
User avatar
Harald

Harri
  • Posts: 1500

ophtalmic

Solved! Thanks.
ophtalmic
  • Posts: 2

itsmylifesoham

thank you!
itsmylifesoham
  • Posts: 2

Harald

Thank you for your patience!
User avatar
Harald

Harri
  • Posts: 1500


Return to Unity