InvertMouse

Hi everyone :happy:. New to these forums, and also new to Spine. Loving the experience so far!

I am developing a game named Clea at the moment. First, here is a screenshot of the characters at 1920x1080 resolution:



The issue is, at 1280x720, the sprites become quite jagged:



Notice the background, floor etc do not have this issue, so it seems to affect only my Spine skeletons. Here are my settings for reference:





When I tried to switch on mip maps, the sprites became blurry regardless of what settings I applied.

Hopefully I can receive some guidance on this. Thank you so much!
InvertMouse
Posts: 3

Pharan

This isn't really specific to Spine.
If you google "unity high resolution sprite jagged", you'll find a lot of people dealing with a similar problem with various solutions.

Have a Unity Sprite and put it in a test scene, then try to scale it down at various sizes.
Then adjust your texture settings until it looks acceptable to you. Spine is not necessary to handle this issue.

For Spine-Unity, if you select the Atlas asset, you will find a "Set mipmap bias to -0.5" button. This just sets a texture property (texture.mipMapBias) not normally accessible in the inspector. This can help a little if you want to handle the problem using mipmaps. The effectiveness may vary depending on your texture resolutions and scene layout/setup.
User avatar
Pharan

Pharan
Posts: 5366

InvertMouse

Thank you for your response!
InvertMouse
Posts: 3


Return to Unity