TeT

Hello. I again have problem with opening file in order version. I always used 3.7.94 and I can open JSON from it in 2.1.27 version (you just needed to delete all new features and weights). But now I made project in 3.8.15 - beta version and now i cant open JSON from it in 2.1.27. I can open it only if delete all bones, but thi is bad way. What can I do in this situation? Thank
TeT
  • Posts: 17

Nate

Do you get an error in your spine.log file? Can you please post the JSON you feel should be imported correctly?

We don't officially support importing JSON data from older versions of Spine. You can always open an older project file with a newer version of Spine, but you should not expect to open old JSON data with a newer Spine version. However, if you data is simple enough, it may still work even though it is not officially supported.
User avatar
Nate

Nate
  • Posts: 9241

TeT

Nate wrote:Do you get an error in your spine.log file? Can you please post the JSON you feel should be imported correctly?

We don't officially support importing JSON data from older versions of Spine. You can always open an older project file with a newer version of Spine, but you should not expect to open old JSON data with a newer Spine version. However, if you data is simple enough, it may still work even though it is not officially supported.
https://drive.google.com/open?id=1ukgfvCKu-AkaZegIExT2P0BeeBcMNqsf Here the JSON.
The project what I working for support only 2.1.27 version, that why I must use it (((
TeT
  • Posts: 17

Nate

Thanks. Spine 3.8 omits some values in the JSON format that 2.1.27 requires. Eg, 2.1.27 wants all keys to have time: 0 while 3.8 omits the time when it is zero to reduce the JSON size slightly and to have less JSON that needs to be parsed.

You can use the JsonRollback tool:
3.8.13 crash pixijs and corrupted project file Search this

Here is your file after processing with the JsonRollback tool:
http://n4te.com/x/6700-Monkey2-nate.json
It can be imported into 2.1.27 just fine.

I highly suggest updating your project, as 2.1.27 is laughably old (hundreds of releases over more than 4 years!).
User avatar
Nate

Nate
  • Posts: 9241

TeT

Nate wrote:Thanks. Spine 3.8 omits some values in the JSON format that 2.1.27 requires. Eg, 2.1.27 wants all keys to have time: 0 while 3.8 omits the time when it is zero to reduce the JSON size slightly and to have less JSON that needs to be parsed.

You can use the JsonRollback tool:
3.8.13 crash pixijs and corrupted project file Search this

Here is your file after processing with the JsonRollback tool:
http://n4te.com/x/6700-Monkey2-nate.json
It can be imported into 2.1.27 just fine.

I highly suggest updating your project, as 2.1.27 is laughably old (hundreds of releases over more than 4 years!).
Thank you. Can you tell me how you do this? I cant understand how to use this tool

---

I do this! Thank you very much!!! :D :D :D
TeT
  • Posts: 17


Return to Editor