Jekelskaz

Hi, how can I scale editor UI? At a resolution of 4K all controls and icons are very small. Thank you
4k.JPG
You do not have the required permissions to view the files attached to this post.
User avatar
Jekelskaz
  • Posts: 3

Pharan

To to Spine>Settings...>Font Size
Choose Extra Large. That will increase the button and font sizes.
User avatar
Pharan
  • Posts: 5366

Jekelskaz

Pharan wrote:To to Spine>Settings...>Font Size
Choose Extra Large. That will increase the button and font sizes.
I'm doing this, extra large fonts in the screenshot is enabled
User avatar
Jekelskaz
  • Posts: 3

Pharan

I guess Extra Large isn't large enough.
Thanks for sharing the screenshot. I've shown it to Nate.
User avatar
Pharan
  • Posts: 5366

Jekelskaz

Pharan wrote:I guess Extra Large isn't large enough.
Thanks for sharing the screenshot. I've shown it to Nate.
I would like to be able to not only increase the font, but the whole UI (icons, buttons, and other controls). Did another screen, it may be useful
2.JPG
You do not have the required permissions to view the files attached to this post.
User avatar
Jekelskaz
  • Posts: 3

Nate

Extra Large is only good for up to about 200% DPI. 4K needs a DPI of around 300%. You can start Spine with a UI scale parameter using either -s or --scale:
Windows:
Spine.exe -s 1.5
Spine.exe --scale 1.5

OS X:
open Spine.app --args -s 1.5
open Spine.app --args --scale 1.5

Linux:
./Spine.sh -s 1.5
./Spine.sh --scale 1.5
Of course you can use any value in place of 1.5. 1 means 100% (the default size), 2 is twice as large, 0.5 is half as large, etc. Technically this scale parameter is marked as experimental, but it should work fine.
User avatar
Nate

Nate
  • Posts: 10070

Pharan

1.5 seems to mess up the fonts. I recommend 2.
User avatar
Pharan
  • Posts: 5366

Nate

On 4K screen you might notice the pixelation less. Actually it seems there is a problem with filtering when using UI scale and not using the bitmap font. This is fixed in 3.0.10.
User avatar
Nate

Nate
  • Posts: 10070

davidle

Hi Nate! I just bought an external monitor screen (LG 4K 27UL550) and I noticed that whenever I open Spine (Pro 3.8.84) in fullscreen it will be laggy but when I reduce the size of the Spine window it will be smoother in animate mode as well as all other actions like drag, zoom in, zoom out...Please have a look on this issue when you have free time, thank you.
davidle
  • Posts: 2

Nate

Congrats on the new screen! There shouldn't be any performance issues with high resolution screens, just of course that there are more pixels and so the video card has to do more work. What video card do you have powering your 4K screen? What framerates do you get in other 3D accelerated apps at 4K resolution? (ie, in games) Spine uses OpenGL and works very similarly to games. Be sure when testing performance of other apps that they don't change the resolution to something lower, as that won't tell us how your video card handles 4K. Lastly, be sure that you have the latest drivers for your video card.
User avatar
Nate

Nate
  • Posts: 10070


Return to Editor