stikkanimate

Using Windows 10 Pro
After Newest update (from 3.8.97 to 3.8.98)
Using 3 screens

After Alt+Tab is pressed, Spine sticks when fullscreened -- meaning it behaves as though it's an 'always on top' and denies other softwares from de-minimizing or taking focus until it is closed (or attempted closed) via the sidebar.

If there is an in-progress file that needs a save, Spine then shrinks to Windowed mode and asks if I want to save the file. At this point, everything is functional again. So the problem is seemingly specific to fullscreen mode with Spine.

This happens upon initialization of Spine. No files need be loaded before this shappens.
Computer restart and Spine restarts don't fix this problem. This only started happening today after I updated Spine from 3.8.97.
You do not have the required permissions to view the files attached to this post.
stikkanimate
  • Posts: 40

Nate

This is the second report about strange app window behavior on Windows in 3.8.98 (the other is here). It's very strange because none of the many Windows computers we've tested on show this problem. Any idea what might be different for you?

We'll likely need to do another 3.8 release, possibly reverting the app window changes. That's unfortunate because those changes fix a number of issues with creating the app window on the correct monitor and sizing when maximizing.
User avatar
Nate

Nate
  • Posts: 10295

Søren

I've been able to reproduce this bug and believe it is caused by a Windows taskbar setting.

Please try enabling Show taskbar on all displays and then minimize Spine to see if you still have the issue.

If this is indeed the cause, we should be able to have a fix out quickly.
Sorry for the trouble!
User avatar
Søren

Shiu
  • Posts: 2427

Nate

The problem was that Windows puts an undecorated window (which is what Spine uses) into a "pseudo fullscreen" mode if the window dimensions match the monitor resolution. That causes the window to not be able to minimize and to always be on top, even though mouse input will go through the window. This is pretty crazy stuff and seems to be undocumented behavior, but we already have implemented a workaround for fullscreen mode. The issue happens if you maximize the Spine window on a monitor that doesn't have a taskbar, since that makes the Spine window equal to the monitor and we only apply the workaround for fullscreen, not when maximized. We'll do a 3.8.99 release ASAP that implements the workaround when maximized.

@stikkanimate You mentioned in your first post that this happens when fullscreened. Are you actually pressing the fullscreen button? Could you be pressing the maximize button? Does the problem occur when the fullscreen button is pressed?

Fullscreen:

Maximize:
User avatar
Nate

Nate
  • Posts: 10295

DenisZ

I noticed that this happens when the "Automatically hide taskbar in desktop mode" option is enabled.
Show taskbar on all displays has no effect.
Full screen application window
DenisZ
  • Posts: 12

Nate

We have also prepared a 3.8.99 editor version. It is ready for use, but hasn't been released yet.

@DenisZ and @stikkanimate Would you like to try it before we release? To do so, run Spine and in the settings dialog click Other... and type 3.8.99. Alternatively you can run from the command line like this:
spine -u 3.8.99
It would be great to hear from you that the minimize problem is fixed before we release it for everyone. :nerd:
User avatar
Nate

Nate
  • Posts: 10295

Raeleus

I came here to make an urgent bug report, but I see you guys are on top of it: https://youtu.be/lzSol_nYs8c
I'll try some of the solutions here and report back.

---

3.8.99 resolves the minimize problem.
Raeleus
  • Posts: 72

DenisZ

3.8.99 works good
DenisZ
  • Posts: 12

Nate

Great, thanks for the confirmation. We were pretty sure it was fixed, but we didn't want to make 3.8.100 release if it wasn't. :D 3.8.99 has been released for everyone! Cheers! :beer:
User avatar
Nate

Nate
  • Posts: 10295

stikkanimate

Thanks for fixing it guys, sorry I wasn't here to provide feedback. New version works great!
stikkanimate
  • Posts: 40


Return to Bugs