Harald

We are happy to announce support for the Unity Lightweight Render Pipeline in our spine-unity runtime!

lightweight-render-pipeline-small.gif

Check out the details in this blog post:
Blog: Unity Lightweight Render Pipeline support
You do not have the required permissions to view the files attached to this post.
User avatar
Harald

Harri
  • Posts: 1032

Shachar Tzin

wow! looks great!
did you need to set a normal map of your for your png atlas to achieve that light effect?
Shachar Tzin
  • Posts: 12

vzlomvl

Great feature. Spine team rock. :rock:
Does this feature support Unity 2018.4? If not, do you plan to support it?
And one more question) Are you planning to add UPM support for the entire spinal runtime? (Unity 2018.4 UPM supports using of the git packages).
Thanks.
User avatar
vzlomvl
  • Posts: 57

Cranktrain

Really glad to see this level of support for LWRP, appreciate all the hard work this entailed.

Annoyingly, Unity have recently renamed LWRP to the 'Universal Render Pipeline', so I'm wondering if that means you've got to go through and match up all the Shader names and so on?
User avatar
Cranktrain
  • Posts: 58

Xelnath

An error occurred while resolving packages:
Package <removed> has invalid dependencies:
com.unity.render-pipelines.lightweight: Version [5.7.2] is incompatible with the selected version [6.9.0]
What do I need to do here?

---

Answer: There are multiple configuration files. Rename the .json to remove the suffix to the correct one for your build.
Xelnath
  • Posts: 408


Return to Spine