djmisterjon

the new version when we "fullScreen" freeze window and freeze macro
we are not able to [win+tab], [alt+tab]
to unlock the freeze, we need to do [ctrl+alt+delete]
and the gpu make screen flash ~~1,2 time !!

my gpu are update
nvidia 1070: v.416.34
spine: v.3.7.43.b
window: 10.1809

Existe a option to disable the fullScreen on spine app ?
thank
djmisterjon
Posts: 45

Nate

That is odd. Are you using multiple monitors? We haven't seen this problem with almost the exact same setup you have. Is anyone else having problems with full screen on Windows?

If the problem is Spine goes full screen when it starts, you can reset your user preferences by deleting this file:

Windows: <user home folder>\Spine\prefs.json
Mac: <user home folder>/Library/Application Support/Spine/prefs.json
Linux: <user home folder>/.spine/prefs.json
User avatar
Nate

Nate
Posts: 8365

djmisterjon

Nate wrote:That is odd. Are you using multiple monitors? We haven't seen this problem with almost the exact same setup you have. Is anyone else having problems with full screen on Windows?

If the problem is Spine goes full screen when it starts, you can reset your user preferences by deleting this file:

Windows: <user home folder>\Spine\prefs.json
Mac: <user home folder>/Library/Application Support/Spine/prefs.json
Linux: <user home folder>/.spine/prefs.json
hum, yes but i would like to work in full screen :)
I also take a look inside nvidia panel to disable all flag and see if is fix but no.




I also noticed that when I start Spine2D, I have an nvidia experience message overlay that appears.
It an alert usually that I see only on videogames.
He seems to consider spine as a video game and he has the same behavior!

Also now in windowed mode i notice the window is no longer responsive to the Window environment, I have to resize manually, it not clip to screen.

And in fullScreen mode , Window environments are just ignored! and i can not switch between app (vscode,photoshop,terminal....) i need to use [ctrl+alt+delete] to call the task manager and un-freeze Spine2D

if you have any idea or suggestion.
thanks


edit: yes i use multi-monitor, but they are disable, and is do same thing.

---

edit2: i just try backup to old version and same issue.
So it can maybe come from new Nvidia driver , or window update.
Spine2D are the only software that do this to me.
All my other software dont do this.
(afterEffect,photoshop,texturePacker,SpriteIlluminator,vscode, nwjs....)
djmisterjon
Posts: 45

Nate

djmisterjon wrote:i would like to work in full screen
To be clear, you are clicking this button to go into fullscreen, right?

I also noticed that when I start Spine2D, I have an nvidia experience message overlay that appears.
Spine uses hardware acceleration (OpenGL) and is basically identical to how game applications are built. This could be why you don't see the behavior with other applications. I don't know why Nvidia would start with their overlay now. Did it start only after you updated your Nvidia drivers? If you go back to a previous 3.7 version, does the Nvidia overlay show? Ah I see your edit, so you see the same behavior in older versions. This is helpful, as it means that the problem stems from Nvidia's update and not from our recent changes that fix some multiple monitor issues. We will make sure we have the latest Nvidia stuff and report back if we can reproduce and fix it. (I don't normally install Nvidia Experience, as it seems like just a bunch of junk that isn't necessary. :) Is there anything in there that is actually useful?)
Also now in windowed mode i notice the window is no longer responsive to the Window environment, I have to resize manually, it not clip to screen.
Sorry, I don't understand this part. Can you explain in different words? Or maybe show a short screen capture video?
User avatar
Nate

Nate
Posts: 8365

djmisterjon

Nate wrote:To be clear, you are clicking this button to go into fullscreen, right?
yes the both seem do same thing and behavior.
Nate wrote:Spine uses hardware acceleration (OpenGL)
ok , i also try one of my app and force to use OpenGL, but the app work fine with the window environment.
I try potplayer because i know we can setup the engine. But i don't know if is good to compare.

or maybe if you know other OpenGL app i can test.
Nate wrote:(I don't normally install Nvidia Experience, as it seems like just a bunch of junk that isn't necessary. :) Is there anything in there that is actually useful?)
no , i use only for the desktop video recording at (60fps), and easy youtube share, also for fast update driver and some VR features.
I never use it for game or software optimisation.
i will try unstall to tell you if is affect spine2d , but i think is more come from last WindowUpdate or the last driver update.
it difficult to tell you when this happened in the time.
Nate wrote:Sorry, I don't understand this part. Can you explain in different words? Or maybe show a short screen capture video?
yes but it will hard because, i use only macro to work with my environment, and video recording don't show macro keys or mouse macro.
i will try to show you a video.
I have to regularly switch from spine2d to other software, because I work closely on my little editor who uses your software in real time.
update v1.1.7a, spine2d,texturePacker,spriteIlluminator,pixijs,nwjs - YouTube
Because of this workFlow, I have to switch often between my applications and your application for real-time editing.
And that happens only recently, but in the meantime I had updates to window 10, nvidia, and spine2d.
I will try to show you a video of the issue soon as possible, tank a lot for you time and sorry for my bad english. ;)

---
EDIT:
Nate wrote:Can you explain in different words? Or maybe show a short screen capture video?
Hey @Nate, i take the time to rec you a screenCapture.
Strangely the screen wont rec when we use [ctrl+alt+delete] for window debugMode, but you will maybe understand.
Please , take look all issue.
My screen freeze a lot , and i can switch between softwares without use [ctrl+alt+delete].
We have huge freeze , each time we unFocus the software.
The video take 2 minute, if you need you can slowDown x0.5 if is too fast.

i add mouse sfx and keystroke to help you understand the video.
and i open some other window task to let show you how the environment should work when spine are ok.
I say "when" because sometime it ok, and sometime it not ok.

spine2dFreeze window10 environement gtx 1070 - YouTube
Thank a lot for help me understand this issue.

---

update to V3.7.46.B
and always the same problem, it's really annoying.
no one encounter this problem? or have solutions?

---

Also do you think this is related to the issue?
Do you have a exclusive mode when you pass your software in full screen ?

https://forums.khronos.org/showthread.php/13703-Windows-Driver-Developers-Please-Add-Option-For-Disabling-Fullscreen-Exclusive

I also noticed, when i use spine, nothing can appear.. volume bar, window taskBar, window alert, window application switcher.. .ext
So i think this issue can be named "exclusive mode fullScreen issue"
djmisterjon
Posts: 45

Nate

Sorry for the delay. We had some major problems with 3.7.47-beta that needed all our attention.

Spine is not using exclusive mode fullscreen. All we do is set the window's "maximized bounds" to the bounds of the screen the window is on, then we set the window to the maximized state. When Windows sees a window sized to cover the entire screen, it automatically hides the taskbar so the Spine window can be on top.

We do exactly the same for normal maximize (not fullscreen), except we reduce the window's maximized bounds by the "insets", so the window doesn't cover the taskbar.

Besides putting the Spine window on top of the taskbar, Windows seems to also change other behavior. With a single monitor, if I fullscreen Spine then alt+tab away, Spine stays fullscreen and on top of all other windows. If I have eg a browser under Spine, I can see the mouse cursor change when I mouse over text, but Spine is on top. This is ridiculous! We don't do anything to make Spine stay on top, literally all we do is set the Spine window size to the full screen and maximize the window.

I don't know why Windows decides to keep Spine on top, nor how to stop it. This behavior is likely why Spine used to take itself out of fullscreen mode when it loses focus. We could go back to that for now, though it's not ideal. We could try something silly, like size Spine 1px shorter than the window size when it loses focus, but this really seems like a hack.

Thanks for the video. In your video, after leaving fullscreen (eg 0:09), it seems Spine doesn't redraw for about 1 second? It's weird I don't see this happening. In 3.7.49-beta we've added some redraw triggers when changing to maximize/fullscreen/restore, hopefully that will help. Though, just mousing over the window should trigger a redraw, so it could be the GPU freezing up and not letting Spine draw for a short time.

It's true that the Spine window doesn't pin to the sides/top/bottom of the screen (this is called "Aero snap"). This is because Spine uses an "undecorated" window, meaning that the normal Windows "chrome" (titlebar and edges) are not used. The amount of deranged magic that Windows seems to think is a good idea drives me nuts! Using an undecorated window sized to the screen is probably also what triggers the other odd Windows behaviors, like keeping Spine on top. Spine looks pretty silly with the native chrome:

AFAIK, the only solution is to either show the native window chrome like this, or we have to implement Aero snap-like functionality ourselves. That is not great since it's unlikely to work exactly like the Windows behavior. Snapping is not terribly hard, but Windows draws an outline to indicate the snapping will occur on mouse up, which is hard/impossible to match.
User avatar
Nate

Nate
Posts: 8365

djmisterjon

hey @Nate
I just make a new update of window , nvidia and spine today, and now maximise button it work fine haha!
I did all the updates at once, so I don't know who corrects what !?

but now if i click on the Maximise button, spine don't take priority on Windows task and i can navigate in window with spine running in background.
So this is fixed for me.
If you add some fix in the new spine 3.7.54, thank you so much!, this has maybe solved the issue!
Before the button FullScreen and Maximise was do the same thing.
djmisterjon
Posts: 45

Nate

We've made some improvements in the recent beta releases, so it's good to hear it's working now. Thanks for letting us know!
User avatar
Nate

Nate
Posts: 8365


Return to Bugs